Failed to open file error in Affinity Designer


#1

Loaded the new plug in and created a new file in sketch-up then set it for shaper and created a svg file. Affinity say “The file could not be parsed.”

Just a rectangle with a pocket and through hole and it doesn’t work. Removed the pocket and hole and the simple square works, then added the hole back in and it doesn’t. Like wise just the pocket doesn’t work. I did not have the time to take them to the shaper tool to see what it makes of the svg file.

I do like that you have the setup now and it will not require me to have to select shaper every time.

Ed


#2

Our SVG files are tested and work with Illustrator. Affinity designer is… touchy. It’s got to do with the way the SVGs are ordered.

Question: Why are you trying to open it in Affinity? If you want to see what it looks like you can just use Chrome. The idea is that you shouldn’t need to even use an SVG editor, you just do what you need in SU and send it to your too…

(I’m sure you’ve got a good reason to open in Affinity, I’m just wondering why)


#3

I have Affinity I do not have Illustrator so things that one might do in Illustrator I would do in Affinity. I’m sure that Illustrator is a much better tool but…

So I guess that Affinity will not be supported?

Ed


#4

So I just went in to look at the files in Chrome… nothing shows up. Then I went to an older file and it shows up with “This XML file does not appear to have any style information associated with it. The document tree is shown below.”

Looks like even in the older version I could not see images in Chrome and that has gone to seeing nothing. At this point I have no way of looking at the files on my computer.

Ed


#5

I didn’t have any trouble opening the SVG created by the new Sketchup plugin in Chrome and viewing the source.


#6

Google Chrome is up to date
Version 67.0.3396.99 (Official Build) (64-bit)

This is a windows 10 machine so those of you seeing things what do you have that I don’t?

Ed


#7

My Chrome and Windows versions are the same as yours. Maybe try to generate another SVG using Sketchup and the new plugin.


#8

Just generated a new sketch-up file and then used the plug-in and still nothing to be seen in Chrome. This is about as simple a sketch-up part as you can get
:

BTW the plug in I have says Version 0.1.2 is that right?

I’m going to load this to my shaper to see what it sees.

Ed


#9

Shaper also sees nothing…

I’m going to remove the plug-in and reinstall.

Ed


#10

I’ve wasted enough time for today.
Removed plug-in, restarted sketch-up to make sure it was really gone, it was. Then closed sketch-up installed plug-in, checked version, same as before.

No image in chrome and I believe this is right as shaper also sees nothing.

For me this is total broken.

Ed


#11

Well, I don’t know what is going on. After I downloaded the update this morning I created a component in Sketchup using the Vcarve export option and was able open it in Chrome and export it into Aspire. After hearing about all your troubles I went back and tried the very same thing in Sketchup and now I can’t generate an SVG that will open using anything. I confirm what you are seeing, Ed.


#12

Ok, this isn’t good! Are you guys on Macs or PCs?

That’s odd because on our test machines here it’s working just fine… (both on Mac and PC)

Can you guys post the files you’re trying to get it to work on?


#13

PC with Windows 10. Here is the SKP. The SVG would not open to upload with a corrupt error. But here Is the one I generated earlier today before all the issues started.

TestPockets.skp (39.3 KB)


#14

Using notepad I opened the svg file…

svg width=“0” height=“0” xmlns=“http://www.w3.org/2000/svg

/svg"

All of the files I try give me the same result with the new plug-in. Not sure where to go from here, I guess see if I saved the old working plug-in???

Ed


#15

Yes, you get the same thing in Notepad as you do when you click on page source in Chrome. Basically an empty file.

"

"


#16

I was able to revert to the previous plug-in to generate the file I needed.

Hope to cut it tomorrow. Today was pretty much a waste with this issue and other things that needed to be done.

Ed


#17

Thank you so much for testing this… let me see if I am clear about what’s going on:

In the first issue you weren’t able to see it in Chrome. Are you sure you weren’t zoomed in? Chrome tends to show you a view that’s really zoomed in sometimes. Also, did you have it set on Shaper export? We default to VCarve/Aspire when SketchUp is started, so if you exported an SVG in that format it wouldn’t work with Shaper. This setting is NOT persistent (yet) when you close and open SketchUp.

@sehast I tried the file you posted and it worked just fine for me. When you say it wouldn’t open are you talking about it not being able to be open via Shaper, Vecrtic, Affinity, Chrome or Illustrator?

Just so you’re aware: We test on Mac and PC. For verification of the output format we test by opening files in Illustrator/On Shaper Origin directly and Vectric. We had a quirky SVG implementation but we’re working on normalizing it. We don’t test SVG reading in Chrome or Affinity so YMMV on those. (We know we need to support them and we’re working towards that)

I’m not at all doubting your bugs, but the one file I have to test IS working for me… What I really need to dig deeper is these SketchUp models that failed export (and the SVGs that came out corrupt). Please do post them here so we can work through it.


#18

The latest information is that the plug-in generates a file with 73 bytes which is in effect means there is no data. I went back to the old plug-in and was able to generated a file, it is 772 bytes.

The svg file is just this (minus some stuff I had to remove so it would show up here:

"svg width=“0” height=“0” xmlns=“http://www.w3.org/2000/svg”

/svg"

That is all that is in the file…

I only use the shaper so yes I’m set to shaper.

So the new plug in has major problems. It doesn’t work at all.

Can you check that the file you have up on google is the same one that your test machine is using, ie reload the plug-in using the file on your google drive?

BTW since the new files have no data I would not expect Chrome or any other program to be able to display any thing, there is simply nothing to display.

I will try and find the solution to why I can not see the files in chrome once there is data in the files.

Ed


#19

I’m with you. On our test machines and files we’re not seeing this. To investigate further I need the files that are causing you problems. Can you post the file that you just tried that failed you?


#20

Something changed over night. I got a third copy of the plug-in off goggle and installed it this morning. I took the same file that had not been working and tried again. This time it worked. I can see it in Chrome, Firefox and Affinity. I did a second drawing and that too worked. So clearly the problem is gone at least for now. I’m hoping that the plug-in was refreshed on google because other wise this is too strange.

I also wanted to mention that I tried the Fabber Starter Kit file and the “hex shape” yesterday and it too failed. I tried it this morning and it worked.

Perhaps this is a case of self healing code that fixes itself over night, petty cool.

Ed