Update wont install on sketchup 2019

I downloaded the update yesterday and today but it wont install on my 2019pro version of sketchup. it does however install on my 2018pro version. I have sketch up closed while installing and select both 2018 and 2019 on the installer. It goes though the install process and takes you to a window that says finish and i click on that and open 2019 and it does not show up with a shortcut for fabber nor is it found under the extension tab. When the installation is finish it redirects me to your site and the site says thanks for installing. Can you help me with this.


just looked again and it shows up in the extension manager but says invalid signature. I have the unrestricted option selected in the settings for the extensions

Are you on Windows or Mac? And where did you get the update from, “My Account” on GetFabber.com?

windows 10. Downloaded from getfabber.com from the my account tab.

Assuming you got the EXE file, what happened when you ran it?

I uninstalled fabber from sketchup just now to see if that would work but no luck. Here is what i tried step by step with screen shoots. Sketchup was closed while doing this.

  1. Opened www.getfabbercom.
  2. clicked on my account.
  3. Checked my subscription is active.
  4. clicked on the download fabber button then in the download dialog box i clicked on the fabber windows and vetric button.
  5. hit the save file button in the Open fabber-setup.exe box
  6. a warring pops up next windows protected your computer. hit the more info button.
    7 hit the run anyway button.
  7. Then the set up dialog box opened and hit English ok button.
  8. selected 2018, 2019 then clicked ok.
  9. then hit install in the ready to install box.
  10. Then the thank you for installing page opened.
  11. Hit the finish button here.
  12. Opened sketchup and the invalided signature warning as shown.

This may have been more info then you need but hopefully it helps. So it seems like it installed it but sketchup 2019 is not recognizing the signature for some reason.

just checked to see if it is still working in 2018 version and it is. Yesterday I also tried just checking the 2019 in step number 8 in the previous post and it had the same outcome.

That’s great, I really appreciate the steps you showed there! VERY helpful.

You’re positive you can’t find the extension anywhere under View>Toolbars?

If that’s the case let’s setup a screenshare so we can get you sorted out.

Thanks i did not think to look their. once i cheeked the box it showed up on the toolbar. Is it because of the invalid signature that it does not automatically show up without checking the box in view toolbars?

Thanks for the help i really like the plugin it works great with my shaper. I am going to meet personally with a few people from shaper and will put in a good word about fabber. I would like to see them endorse this for us folks you are used to sketch up and don’t want to take the time to learn fushion 360 at this point.


Sometimes when you install an extension it doesn’t show up right away. Usually you have to restart SketchUp, but sometimes a full computer restart will make it show up.

I’m so glad you like the plugin! We’re actually working on a newer cloud based version that we’ll have coming along soon! (it’ll support both Fusion AND SketchUp!)