Units of automated toolpaths


#1

How do I make the automated toolpaths use metric instead of imperial? My drawings and aspire file are setup in metric allready.


#2

The best way to do it is to go into SketchUp and change the drawing units. You do that by going to Window>Model Info:

7fbcea27e20e4afcaa85d5593dd7f034558c1270

Just change it to something like decimal MM and try the export again. You should be all set after that.


#3

Hello Eric, I have allready tried that. It doesn’t work. I tried to do a test with a component of 18mm thickness. I can see in the ruby console that during export it is converted to 0.709 inches.


#4

I think this can be best answered with a quick video, check this out:


#5

When I export the 300x300mm and 18mm (3/4") thick part and import the svg in my 1220x2440 and 18mm thick sheet (4x8x3/4) the topview size is no problem. It is 300x300. But as you can see in the layer name it converted the size to 0,703. This should be 18. So when I try to get an automated profile cut it just cuts 0,7mm deep.

In your example you go from 1 inch thickness to 0,04 (or 1mm). Just try a toolpath and check the cut depth.


Inch and Metric
#6

Ahhhh, sorry, I totally forgot to address the cut depths. For the moment there’s not an easy workaround for that. What I’d do is let the script build the toolpaths with the imperial depths, then go into each toolpath and adjust the depths. I know that’s not ideal right now, but it’s something.

Do you have cuts with tons of toolpaths, or just a few?


#7

No not a lot of toolpaths but I thought it would be important for you to know this.


#8

We do appreciate it. We’ll let you know when we get some true metric support.