Unable to parse the given SVG file


#1

Have a Adirondack chair in Sketch trying to import in Aspire. Get the following error:

Unable to parse the give SVG file - could not find viewbox information?


#2

If you can post the file up here I’d be happy to take a look for you. I’d like the SketchUp and the SVG file if you can post both of them please…


#3

Untitled.skp (311.5 KB)


#4

Can’t upload the svg file. Get following

Sorry, but we couldn’t determine the size of the image. Maybe your image is corrupted?


#5

I am having the same problem.


#6

I’m going to enable “ZIP” files too, so you can zip 'em up and put them on here. That may solve the problem.


#7

I figured out my problem. I was not hilighting the components before I ran the plugin. All is good now.


#8

Ah good! Glad that was easy!

Any chance you could share what you’re making? I’d love to see what you’re up to.


#9

I have had this same issue multiple times. I think I have figured out what causes it.

If you copy a component in SketchUp and then alter it from the original. Then if you export to svg file without making it an unique component you will get the “Unable to parse the give SVG file - could not find viewbox information?” error in VCarve.

I went back to the altered component and created it as its own component. Then exported it to svg. It worked for me the second time. I have tried this multiple times with success.

Hope that helps.

Todd


#10

Would it be possible to share your SketchUp model, and the SVG file that caused that? I’d like to reproduce it here.


#11

SVG Export Model.skp (252.6 KB)

Eric,

Attached is a smaller version of the model that caused the issue. I am making a jig for to cut the back leg on my CNC. I stacked six pieces of plywood that is one component “Jig, Plywood, 4.25x18”. Then moved the “Leg, Back, Left” component into the plywood jig. Next, I used the Solid Tools, Trim function to remove the leg space from the plywood jig. During this process the top two pieces of the jig get disassociated from the original component. But they are still components. If you select one of the top two pieces then export it to an svg file it will let you. When you go to VCarve and try to input it the error appears.

Hope that helps.

Todd


#12

Hi Todd, not sure but the pieces of plywood show as groups on my system and I believe they need to be components to work with Fabber. I converted to components and it seemed to work.

Glenn


#13

You’re correct, they all need to be components to work. All you need to do is select the ones that aren’t components, right click them, and select “Make Component” and you’ll be good to go.