Plugin not working today 09-26-18


#1

Pleasantly surprised to see message regarding needed fix today. Sadly, it did not help.
Dialog box cut/paste:

www.GETFabber.com
exporting selected components…
dpi: 90
exporting to VCarve
tool diameter: 0.25"
Error: #<TypeError: wrong argument type (expected Sketchup::Group)>
c:/users/rww/appdata/roaming/sketchup/sketchup 2018/sketchup/plugins/exportsvg/main.rbs:240:in equals?' c:/users/rww/appdata/roaming/sketchup/sketchup 2018/sketchup/plugins/exportsvg/main.rbs:240:inblock (2 levels) in export’
c:/users/rww/appdata/roaming/sketchup/sketchup 2018/sketchup/plugins/exportsvg/main.rbs:236:in each' c:/users/rww/appdata/roaming/sketchup/sketchup 2018/sketchup/plugins/exportsvg/main.rbs:236:inblock in export’
c:/users/rww/appdata/roaming/sketchup/sketchup 2018/sketchup/plugins/exportsvg/main.rbs:221:in each' c:/users/rww/appdata/roaming/sketchup/sketchup 2018/sketchup/plugins/exportsvg/main.rbs:221:inexport’
c:/users/rww/appdata/roaming/sketchup/sketchup 2018/sketchup/plugins/exportsvg/main.rbs:27:in block in <module:ExportSVG>' SketchUp:1:incall’

Still working on it, or is this unique to my machine?

Jeff


#2

Everything is fine on our end and with most other users, so this looks to be unique to your machine… Did you change anything or install an update?

Also, is this still happening on the “Fabber Starter Kit”?


#3

Okay - items I tried to export are part of a relatively large file. Designing this house floor by floor, and have downloaded several unrelated items from 3D warehouse in addition to what I’ve drafted. Somewhere in this file something is causing a block in exporting. File size is just under 40k.

Copied/pasted the 3 items in question into a new draft by themselves, and export worked.
So- this means the more complex a model becomes, the more variables introduced can confuse the exporter, evidently(?)

jeff


#4

The exporter only reads what you have selected… When you export those parts out of the whole house model do you have them selected, or are you trying to export the whole model?

Would it be possible for you to post the problem model, and the one that works so I can take a look at the difference between the two?


#5

“The exporter only reads what you have selected…”

  • Interesting. All I selected were the three pieces, not entire model. “blocked” from main draft, yet fine in a fresh one. Logic suggests I’ve got something toggled on in original file that’s foiling the export.

    I am under strict rule on this one - client is extremely sensitive to privacy, and I am unable to release any copies of the full layout.

Only other thought pertains to file management. New computer utilizes SSD as well as a disc drive for bulk storage. I regularly receive notice from Sketchup regarding autosave backup files for errors in saving to drive “c”. Should not be doing so, as that’s the SSD with windows, but sadly, I am unable to determine how to smooth out that issue. I was sold on the concept of solid state drive, but it does bog things down and seems to confuse windows in this manner . Could this be the hiccup that’s tripping up the export process here?

jeff


#6

Your SSD, or any other hard drive won’t have anything to do with it.

I can only guess, but maybe you have a component within a component or something like that… Unless I can work with a file I really can’t tell you much more than that. If you wanted to do a private screen share I could help you that way… Just PM me here.

The only other way I could help you is if you could somehow re-create the problem with a new drawing that’s not sensitive and post it here…