Odd behaviour is back but


#1

A short while back it appeared that Affinity Designer was unable to read these files and the problem turned out to be that the files were not being generated correctly, ending up with no data in them. The next day things seemed to have fixed them selves.

The problem came back today but I think I know what the odd thing is about. Now I have to do some more testing to be sure but…

If I open sketch-up and do a small drawing then forget to select the part there is no error message just the truncated output file. I think the not having a part selected is the issue. But I might be wrong. I managed to do this several more times so I think I’m on the right path.

I know this is an issue that I have to deal with, a part of the process but, it would be nice if the plug-in figured this out and gave an error message before writing the 73 byte file. BTW I now check the file size and if it small like this I know I messed up so I delete the file and go back to fix it.

I’d like a couple of others to try this a report back their results. Again start a new sketch-up session then draw some simple part then attempt to generate a file using the plug in set to shaper, without the part being selected in shetch-up… you don’t have to look at the output just check the size.

Ed


#2

Ed, I tried the process you described and ended up with the same result. Drew up a part in Sketchup, did not select it, exported with Fabber and got a 70 byte file that AD would not open. Went back to Sketchup, selected the part, exported and everything looked fine in AD and Origin.


#3

Clearly one needs to select the part as part of the process but if you forget it would be nice to see an error message like “nothing selected” and no file produced.

At least this failure has got my attention and perhaps I’ve learned my lesson and will remember to select the part every time in the future.

Ed


#4

Nice catches guys!

We’re in the process of addressing some of these issues. We had an initial bug where the plugin would fail if you had stuff other than components selected and we patched that. This is a good one too, it should totally tell you if you don’t have anything selected.

PS, just so we’re on the same page, when you DO have stuff selected and you export, are you seeing any issues with Affinity designer, or is that now working?


#5

At this point valid files from the plug-in are read by Affinity Designer. Or at lest the ones I’ve made work.

I’ve got two new projects under way so I’ll get some more use of the plug-in this week if all goes well. Simple designs but fun projects.

Ed


#6

Awesome! Please do post progress pics!


#7

My trials have all shown up in AD.


#8

What does AD stand for?


#9

Sorry, Affinity Designer


#10

Duh! Glad it’s working for you!