New Install: macOS Mojave + SU19 - Not Working


This is probably not a bug since I have not gotten the extension to work yet. Install seemed to go fine though one or two things seem to work a little different from your video(s):

  1. setting CNC machine type only comes up after clicking the exportSVG icon and not when the tool icon
  2. svg file creation does not start automatically after setting the CNC machine type

Beyond that, I have had no success exporting an SVG yet. My SU file is attached. My axes appear to be correct.


test.skp (29.8 KB)

Re-download the plugins again and try now. We JUST updated them so they won’t redirect you to the website. Post here and let me know if that works… Again, make sure you download a fresh copy.

My install version was 0.1.2. Deleted that from SU.

Downloaded latest version dated 03/01/19 from GDocs.

Installed latest version. Success.


Side Note: Once installed, the latest version also showed version number as 0.1.2.

Awesome! Glad you’re up and running. Let us know if you’ve got any other questions!

Hi Eric,

  1. when I click ‘export svg’ a dialogue pops up, I select adobe illustrator, hit save - and nothing happens.

  2. when I click ‘get fabber’ icon a ruby console appears and a save dialogue appears. After I hit save, it does save a SVG file to the desired location. The file appears blank if I use a 2D drawing. When I make the drawing 3D, it displays the vector, but only what appears to be a top down view.

I tried duplicating and placing the 3D objects on each potential plane - selected the components - exported again - same result x 3. Top down view.

System specs: macbook pro 2018 / MacOS Mojave 10.14.3 / sketchup Pro 2019
version: 0.1.31

Can you post a copy of the model you’re having trouble with?