Internal groove doesn't render


#1

Trying the new Fabber Sketchup plugin, exporting for Shaper Origin. Model is attached. It’s a simple block, with a square offset groove on the top surface:

The svg export gives:

Here it is with the <svg> tag fix:

The groove is treated as a pocket on the whole surface.

Regards,
Charlie

fabtest.skp (123.1 KB)


#2

Thanks for posting the files. I’ll dig deep later today for you.

Are you seeing the same result on the cutting board in the Fabber Starter Kit?


#3

Hi Eric, can you please send me the link for the working download.


#4

Same result:

Fabber%20Cutting%20Board

I think you need to make the interior path black fill/black stroke:

Fabber%20Cutting%20Board%201

This might be a challenge to detect in the shaper model. Something like “is this face completely contained in another face”?


#5

Yeah, I see what’s going on. Since we do both Shaper Origin and Vectric there’s a conflict there… We do it correctly for Vectric, but there are two pockets stacked on top of one another as far as Origin is concerned.

Let me look into this one and get back to you. An immediate workaround is to change the color of the internal “pocket” to black on black…


#6

Thanks. That’s what I did with the previous SVG that I posted.


#7

It shouldn’t take us long to patch this one up. Thanks for pointing it out.


#8

We’re on this one. Developers are off this week, but will be back at it next week. It’s partially working in that if you want to make stuff on Origin you can export as normal, but you’ll have to change the paths on tool, or in an SVG editor beforehand to workaround this groove issue.

All other models should be fine.