Installed but not working


#1

I get this error with a sad face in the small overlay panel.

I downloaded and installed into Sketchup Make v17.3.116 using the extension manager.

No errors on install and Fabber is enabled.

But if I open up the sample document and select component in the sawhorse, the small data panel has two ‘faces’ in it…

This is the error I get…

Error: #<NameError: uninitialized constant Examples::ExportSVG::Date>
/users/neil/library/application support/sketchup 2017/sketchup/plugins/exportsvg/main.rbs:58:in export' /users/neil/library/application support/sketchup 2017/sketchup/plugins/exportsvg/main.rbs:21:inblock in module:ExportSVG
SketchUp:1:in `call’

Feedback welcome.


#2

I think we have that one figured out. I’ll have an update for you Sunday if not sooner…


#3

I just downloaded and getting a similar error in Sketchup

Error


#4

@neilc Did I send you an updated install file yet? @sehast I believe we have a fix for this. I’ll send you and update via DM here.


#5

No. I did not get anything from you unless it’s in a spam folder.


#6

Just sent it as a DM here.


#7

Looks like I’ll need the updated file as well. Received same error as posted above, and VCPro for shopbot does not show the gadget either. Running windows 10
jeff


#8

Okay - found my way to the new file and Sketchup is working with it, still no luck getting VCPro to acknowledge.
jeff


#9

What version of Vcarve are you running?

And you’re not seeing it in the gadgets menu under “Fabber”?


#10

VCPro Shopbot Edition 8.5. Not showing up in the gadgets as demonstrated in the video.
jeff


#11

Ah, I think because you have the ShopBot edition the gadgets aren’t getting automatically deposited into the right directory. If you want we can screen share and I can fix it for you real fast, and then we can address that for everyone else in our installer…


#12

Sounds good - let me know how to initiate that process.


#13

Do you know how to install a gadget? If that’s the case you can do it yourself, if you’d rather do a screenshare I’ll DM you my email address


#14

Downloaded the latest July 13 version, installed and get the same error as before.


#15

Almost there - Arrived at:

Users>Public>Public Documents>Vectric Files>Gadgets>VCarve Pro - Shopbot Edition V8.5

which at this time simply contains a “read me” file.

Can you enlighten me on how to place the gadget there?

Thanks!


#16

If you look in the “Vectric Files” folder do you have one for Aspire or VCarve? If so you can copy the LUA script from there right into your ShopBot edition version of VCarve and it’ll work.

If you don’t have any Vectric files in the folder you can run the installer again and just tell is you have Aspire or VCarve and those directories should be created.

If that doesn’t work I can give you the LUA script and you can just open your version of VCarve, go to “File” and then to “Application data folder” and just manually copy it into the gadgets directory.


#17

Okay - Vectric Files contains a VCarve shopbot edition 8.5, but no LUA scripts there. Another folder exists for a VCarve Pro 9.0 free trial. Nothing in there either.

By searching OProgram files in the directory, I can find an Lua folder in VCarve pro folder, containing “ppVariables” and “strict”. Neither of which appear to be related to this gadget. Unable to locate where the installer is actually placing the LUA script. Just cannot find it.


#18

Is there a folder called “Gadgets” in that VCarve Pro ShopBot edition folder you found?


#19

Vectric Files
Gadgets
VCarve Pro - Shopbot Edition V8.5
no contents
VCarve Pro V9 Trial Edition
no contents


#20

Ok, try this:

And do it with this gadget file:

https://drive.google.com/open?id=1WYKZVTrQisWBB1mlkKj7nqSeQI3WOcE8

Let me know how that goes.