Installed but get a Ruby Console error

Aspire V 9.015
Sketchup Make 17.2.2555 64-bit

Don’t know how to attach file I’m trying to use.Trophy case.skp (290.4 KB)

Here is the dialog I’m getting when I select the Fabber extension.



Opened Sketchup
Loaded file
Selected all the parts of the file (using bounding box)
Selected Extensions/GetFabber

Get the attached dialog

Can’t get any further then that.


We’ve got an update that I believe fixes that. I’ll message you the link to download it. All you’ll need to do is run the installer and test again to see if it fixes it.

Are you going to send it to my email? Just need to know where to watch for it. Thanks!

Just sent it as a DM here.

I am getting the same error - could you send me the updated installer?


Just sent it. Let me know how that works

OK. New plugin downloaded and installed. Tried the attached file and got the following errors:

Butcher block table.skp (178.0 KB)

We will have to wait for the experts but when I looked at your model I noticed that you have the blue (vertical) facing the tall way so at the very least you need to fix that. There is a short video provided here that shows you how to do that axis change. Might be other issues but I noticed that right away.


There are two things going on here… You’ve got some axes orientated the wrong way, that explanation is here:

There’s another component here throwing an error… I’m going to go through this one bit by bit to figure out what’s happening. I’ll report back soon.

Ok, I sorted it. It was simple but not at all obvious (and something we definitely need to fix)

Check that out, between this simple fix and the axes fix you should be there!