How to post bugs


#1

Hi there! While we work really hard to make sure that our software works well, bugs do come up especially in this early stage. We’re going to squash them as fast as possible. The best way for us to do that is:

  • To give a detailed description of the problem. Walk us through what you were trying to do, the steps you to, the results you expected and what you actually got.

  • Screenshots are great, please post them!

  • Files are great! Post them!

  • Always tell us your SketchUp version, Vectric version, and what tool you’re trying to cut on.

  • Please keep it to one bug per thread.

If you all can do this, it’ll make it far easier for us to help you out, and fix issues when they come up.


#2

#3

Well I didn’t get very far. The plug in seems to have been added to my windows version sketchup 2017 free version. Your sketchup file loads and I picked the “tool box” as the demo showed but when I tried to use the plug in I got this error message:

Error: #<NameError: uninitialized constant Examples::ExportSVG::Date>
c:/users/edward.drwho/appdata/roaming/sketchup/sketchup 2017/sketchup/plugins/exportsvg/main.rbs:58:in export' c:/users/edward.drwho/appdata/roaming/sketchup/sketchup 2017/sketchup/plugins/exportsvg/main.rbs:21:inblock in module:ExportSVG
SketchUp:1:in `call’

I have no idea what that means but I’d have to guess you do. So what did I do wrong or not understand?

Ed


#4

That isn’t very far! So I assume you got the plugin installed and the toolbar showed up just fine?

When you had the toolbox selected, did you have the whole thing selected, or just one part?

What were you trying to export to, VCarve, Shaper, or something else?

Also, have you tried just a single part on either the toolbox, or something else?


#5

Yes the install seemed to work and I have the tool bar. I tried several of the items you have in the Fabber Starter Kit.sky file with the same results. I started by trying to do what you did in the video and selected the whole tool box, but since have tried just one component with the same results. I also tried the saw horse parts and same thing.

As soon as I try to use the plugin the error message comes up. You don’t see the dialog where you get to pick Shaper, I don’t get that far.

I will try making a file of my own to try with just a simple part and see what happens in case the error is related to the skp.

Edit:

Tried a simple rectangle with a hole in it but same error.

Ed


#6

What’s your setup? What version of Windows and SketchUp are you on?


#7

Windows 10, Sketchup 2017 (free version).


#8

I’ll direct message you. I’d like to setup a screenshare to see it first hand if that’s OK…


#9

Sure, let me know what I need to do and we can take a look.

Ed


#10

Follow the steps here:

https://plugin.sketchthis.net/screenshare

Send me over the login details and your phone number and we can figure this out!