First test had 2 issues


#1

Just made a random shape, grouped, ran the export.

  1. svg did not reflect the shape
  2. File naming - tried to overwrite previous test.svg file and got the usual warning asking if I wanted to, selected yes but is created a new file named test.svg.svg

Component selected:
ScreenClip%20%5B6%5D

File naming:
ScreenClip%20%5B4%5D

SVG created:

Also forum is blocking file uploads of svg and skb:

I’ll provide files as soon as enabled.

RMW


#2

Taking a look at your image of the SketchUp model I can tell that you don’t have the blue axis in the right orientation, that’s root of your issue.

Check out this video to see how to resolve that (it’s easy!)

Also, that double file extension thing is on the list of stuff to fix.


#3

'splains that.

Learned something, i.e. that the axis of a component doesn’t change when they are later rotated. I suspected I was seeing some other face but couldn’t figure out how your toolbox would work given you didn’t have to lay the individual component out before running the addin.

That, and I should read (view?) the directions first…

Thanks!

RMW


#4

Still having issue 2 i.e. the file naming:

ScreenClip%20%5B8%5D

And uploading files.

Thanks.

RMW


#5

Glad it worked out!

We do know about the file thing, and I know it’s annoying. You’ll see an update soon on that. Glad you figured out the axis thing. It definitely warrants it’s own video so I’m glad I was able to make it to help not only you, but others.

Hopefully in the future the axis thing will get easier.

And you are correct that once you set an axis for a component you can more/rotate it anywhere. We really wanted people to be able to design parts as they exist in real life and not have to deal with laying them flat or anything like that. WYSIWYG (or as close to that as we can be)