Feb 1, 2019 need update?


#1

When I went to use the tool today it wanted me to update, got the file then tried again and it says I still need the new file. Am I trouble shooting problems I’ve had in the past or is the file not been updated?

Ed


#2

I’m having the same issue. Can someone from Fabber lend a hand? I am currently at a stand still waiting a fix.


#3

When through the other fixes that I have had to apply and none work so I have to guess that the file out there is not been updated so I too am dead in the water until that happens.

Ed


#4

I just tried to run the plugin with the same results. Uploaded the new plugin, same result


#5

Hey all! Update is posted! Sorry we were a bit behind on that one. Squashing a few bugs!


#6

I loaded the new plugin and when I select my component and run it, I get the following error message:

www.GETFabber.com
exporting selected components…
dpi: 72
exporting to Shaper
tool diameter: 0.25"
Error: #<TypeError: wrong argument type (expected Sketchup::Group)>
/users/ebelg2000/library/application support/sketchup 2018/sketchup/plugins/exportsvg/main.rbs:240:in equals?' /users/ebelg2000/library/application support/sketchup 2018/sketchup/plugins/exportsvg/main.rbs:240:inblock (2 levels) in export’
/users/ebelg2000/library/application support/sketchup 2018/sketchup/plugins/exportsvg/main.rbs:236:in each' /users/ebelg2000/library/application support/sketchup 2018/sketchup/plugins/exportsvg/main.rbs:236:inblock in export’
/users/ebelg2000/library/application support/sketchup 2018/sketchup/plugins/exportsvg/main.rbs:221:in each' /users/ebelg2000/library/application support/sketchup 2018/sketchup/plugins/exportsvg/main.rbs:221:inexport’
/users/ebelg2000/library/application support/sketchup 2018/sketchup/plugins/exportsvg/main.rbs:27:in block in <module:ExportSVG>' SketchUp:1:incall’


#7

Well the update isn’t working for me, it just wants to be difficult I guess. It seems that every other update it works fine but I’m on the odd cycle so I guess I’m just out of luck again.

I’ve installed, un-installed, rebooted, and just about anything that I have had to do before but still keeps saying it needs a new version. AHHHHHHHHHHHHHHHHHHHHHHHH

Ed


#8

I’m still not able to use the plug-in. I spent another hour today trying to get it to work and I’ve come up short.

Does anyone have the Feb. update working?

Ed


#9

I just tried reloading the plugin. It worked on a quick sketch I made but when I opened my latest project it still gives me the same error message I posted earlier


#10

Ok, everything should be fixed now. If you’re having issues do this:

Close SketchUp and re-download the Windows installer.

Run it (make sure you have the SketchUp plugins checked off)

Re-open SketchUp and try it. You should be good to go now.

If anyone has continuing issues feel free to post in this thread, or DM me here and we can screen share so I can get you sorted.

@reible


#11

Eric, it looks like I can get it to work on a couple of older SU designs, but when I try it on any of the components in the attached file I get the error message posted above. Any help would be appreciated.

Glenn

Piano Stool.skp (325.3 KB)


#12

Tried again this afternoon and still can’t get a fresh copy to load.

Just now I tried this:
Used the link that comes up in sketchup, download plug-in, used manager in sketchup to remove “old” plug-in. Shut down sketchup and bring it back up to be sure the plug-in is gone and it is.
Shut down sketchup again, did a reboot of the computer, then went to download directory found the plug-in (dated some minutes ago) and run it.
Go back into sketchup, the new plug-in is there and try it and it is still coming up with the announcement that I need to get a new copy of the plug-in.

I’ve tried several variances of this and none of them have worked. I even ran a program to remove the plug-in to make sure I didn’t have a stale copy. Just one of those frustrations that I have with this plug-in and updates, sometimes it works fine and other times I have no idea what goes on but it just doesn’t seem to work.

Ed


#13

Ed, do you want to do a screen share? Sounds like you’ve got something weird going on there. If you send me your email address via direct message here I can set it up.


#14

I solved your problem!

Do this: Select the parts that make up the stool, go to Edit>Copy

Then make a new model

Go to Edit>Paste

Then try again.

This is an odd bug we’re seeing from time to time. We haven’t pinned down what’s causing it, but copy/pasting is a reliable workaround.


#15

Eric was able to solve my problem too. This only effected windows version so you may have been on a mac and wondered what my problem was…

So if you had the problem it is gone now, just go back and download the plug-in and all will be right again.

Ed


#16

If anyone else is having issues try re-downloading the plugin and installing it. If that doesn’t work let me know and I’ll get you setup.


#17

Eric, this seemed to do the trick. Thanks for the workaround,

Glenn


#18

Glad it helped, and sorry for the bug!