Version Number incorrect? <solved>

i signed up. But when I download and install the .rbz file in Sketchup, I don’t see a version under extension manager. I’m on a mac.

Icons are broken too. And if I click on ‘getfabber’ in the Sketchup menu under “extensions” it tells me beta is expired.

Finally, only after I signed up for an account do I see that this might cost $5/month? Is that right? Nowhere did I see pricing explained.

What’s going on?


Ok, let’s go through these one at at time…

You’re not seeing version 1.1.1?

That’s a fix that’s coming in an update next week. Stay tuned for that.

Yes, this is a subscription service. When you sign up it says so. To stay up to date on the plugin we do require that you subscribe. You can cancel at anytime, but you’ll lose access to priority support and premium content.

I don’t see any version info - it’s blank. I’m running Mac Sketchup Make 17.3.116

I had the beta running from last fall. Signed up with this new version, downloaded and installed. Even tried removing the installed version in Extension Manager and reinstalling.

The subscription is not clear that it’s a monthly charge until after you sign up and even then it says next payment in one month. You might want to clarify that.

Thanks -


We’ll take a look at our wording, thanks for pointing that out. Again, you have full control over your subscription and can stop/start it anytime.

Very odd that you’re not seeing a version number… Did you download your copy fresh from our site when you purchased?

Ok - figured it out.

You have to uninstall the old version, quit Sketchup, relaunch and then install.

Now it shows 1.1.1

One other item - when I select a component and click on the icon, the save-as dialog shows this:

Looks like you add an .svg to whatever I type in so not sure why you are pre-filling with anything…


We’re on it!