Error when saving SVG

I just purchased Fabber and am getting an error on the 2019 version of Sketchup I installed yesterday.


exporting selected components…
dpi: 90
exporting to VCarve
tool diameter: 0.25"
Error: #<NoMethodError: undefined method each' for " ":String> c:/users/back/appdata/roaming/sketchup/sketchup 2019/sketchup/plugins/exportsvg/main.rbe:337:inexport’
c:/users/back/appdata/roaming/sketchup/sketchup 2019/sketchup/plugins/exportsvg/main.rbe:34:in `block in module:ExportSVG

Can you post the file you’re having trouble with here so I can take a look at it?

I just installed today and tried for use with a Glowforge. I get this when trying to export to .svg in both SketchUp 2018 and 2019:


exporting selected components…
dpi: 96
tool diameter: 0.001"
Error: #<TypeError: wrong argument type (expected Sketchup::Group)>
c:/users/dcox/appdata/roaming/sketchup/sketchup 2018/sketchup/plugins/exportsvg/main.rbe:355:in equals?' c:/users/dcox/appdata/roaming/sketchup/sketchup 2018/sketchup/plugins/exportsvg/main.rbe:355:inblock (2 levels) in export’
c:/users/dcox/appdata/roaming/sketchup/sketchup 2018/sketchup/plugins/exportsvg/main.rbe:351:in each' c:/users/dcox/appdata/roaming/sketchup/sketchup 2018/sketchup/plugins/exportsvg/main.rbe:351:inblock in export’
c:/users/dcox/appdata/roaming/sketchup/sketchup 2018/sketchup/plugins/exportsvg/main.rbe:337:in each' c:/users/dcox/appdata/roaming/sketchup/sketchup 2018/sketchup/plugins/exportsvg/main.rbe:337:inexport’
c:/users/dcox/appdata/roaming/sketchup/sketchup 2018/sketchup/plugins/exportsvg/main.rbe:34:in block in <module:ExportSVG>' SketchUp:1:incall’

That’s a good one, can you post your SketchUp model so I can take a look at it?

MC-101 GLOWFORGE.skp (9.5 MB)

Alright, I got you all sorted. This is actually a big we’re working on. Fortunately there’s a super simple workaround:

Try that and let me know how it goes.

That worked. Thanks!

Awesome! We’re aware of that bug, but it’s been an odd one to track down. Files like this will help for sure. Happy making!